Thursday, August 26, 2010

Windows Mobile POP access on GMail failing to retrieve e-mails

So, I've been using my Samsung Omnia for over an year to collect messages from my GMail account using POP. But, from time to time, something strange happens, and my Outlook or whatever Windows Mobile default mail client is called, suddenly stop retrieving e-mails. Connection is fine, logging is fine, retrieving is ..not fine.
So, the workaround for this, although you can loose some e-mails in your WM client, but don't worry, you'll have them all in your GMail interface (well, not actually loosing from your mobile, ..you'll just have some e-mails on GMail that will not get fetched to your smartphone), is that, when you actually notice that no e-mail is being retrieved anymore, go to GMail account > Settings > Forwarding and POP/IMAP and select "Enable POP for mail that arrives from now on" and click on "Save Changes". Then, go to your WM smartphone and click on "Send/Receive", and suddenly, it works again. And, of course, you'll not retrieve the e-mails from when it started to fail to work, till the moment you checked that radio button on GMail interface. That's all!

Friday, August 20, 2010

FortiGate + FortiAnalyzer + FortiManager setup

So, I had to setup a configuration built of 3 boxes in the subject. First thing I did, was to upgrade everything to the latest versions of firmware - 4.0 MR2 patch 1. All fine. I got to connect FG to FA, FG to FM, but there were problems in connecting FA to FM, so I can administer everything through one single interface.
So, it didn't work. No way..FA and FM didn't connect. Anyway, after a support ticket to Fortinet, the correct versions that will connect are:

Fortigate v4.0 MR2 patch 1 - build0279
FortiManager v4.0 MR2 patch 1 - build0348
FortiAnalyzer v4.0 MR2 (without patch 1) - build 0198

Thursday, August 5, 2010

software RAID grub problem

So, after correctly configuring a software RAID 1 (mirror) in a Linux installer, after rebooting, only if the /boot partition is part of a mirror, you'll get a grub prompt. Now, you can search Google for what you can accomplish from there, or you can read this. :) What can I say, I've searched Google before you. Anyway..you'll get this:

grub>
First, you'll have to type this, and you will get the location of grub setup files:

grub>find /grub/stage1 
(hd0,0) 
(hd1,0) 
So, if you have SATA, (hd0,0) stands for /dev/sda, and (hd1,0) stands for /dev/sdb - it will be hd* for IDE. So, to make sure you have grub install on both MBR on both drives of the mirror, type this:


grub>device (hd0) /dev/sdb
grub>root (hd0,0) and then:
grub>setup (hd0) 
grub>quit 
 This actually changes MBR to /dev/sdb (not the usual /dev/sda) and copies necessary files to boot. After reboot, it will still load grub from /dev/sda, but if something happens to it, it will successfully start your Linux from /dev/sdb.